User Tools

Site Tools


scanlook-pc-release-notes

ScanLook PC (Point Cloud) Release Notes

The “Pre-Release” versions can be found here:

The most recent official release can be found here:

If you have a Nodelocked version, the update should be at the same link you were provided. If you don't have it, create a support ticket and request the link. If you are unsure, look at Help About. If the Registration Info is not blank you are using a Nodelocked version (meaning, no dongle required).

For completeness, click here for TerraDrone and TerraPOS setups

Version History

Version 1.0.275, October 18, 2021

  • Yikes! The Hesai scanners wouldn't process properly. A minor bug requiring a hot fix.

Version 1.0.274, October 15, 2021

  • Added prompt for Append, Overwrite or Cancel on CreateStrips command (same as manual mode).
  • Added RQM8 to sensor list. Default BS is 90, 0, 180.
  • Fixed bug just introduced properly selecting Ultra vs Alpha Puck (made while fixing HD32 vs Puck).
  • Fixed Create Strips where a final 0-length strip could get created.
  • Create Strips will optionally create events if necessary.
  • Fixed very minor bug with projects that start/stop the scanner while in motion clipping the data incorrectly (for some scanners).
  • Updated Graphics ocx to better support strips.
  • Editing the grid to manually add strips updates all of the events, times, and lengths approprietly and graphics as well.
  • Posted a video to demonstrate how Create Strips works.
  • Fixed NCTech Measure bug. (folder vs file)

Version 1.0.273, October 6, 2021

  • The IE file validation has been slightly updated/improved.
  • Fixed the Puck vs HD32 selection, again. This time for good.
  • When using the top file (run-time), a check has been added to pick the best data (INS or GPS).
  • Added Tools::Create Strips and a few parameters to support it on the Options::General Parameters dialog.
  • When Graphics loads it automatically loads the strips as well. O for each of strip, X for end.
  • The las kml's (in output\output*.kml where offset by the current leap seconds.
  • Now when using the output\output*.kml files, there is a View File hyperlink that will launch the selected las/laz file with the default viewer.
    • If the files laz/las files have been moved, the kml can be edited manually to point to the proper location.
  • Systems that do not collect a lidar\gps*.csv at run-time but that do collect a .top file can now generate kml's.
  • On Reset, all versions of the corrections (Q4, RPH).
  • The Project Info report now includes the moment of first movement and the end of movement.

Version 1.0.272, September 23, 2021

  • Fixed Puck vs HD32 bug on new projects, again, finally.
  • If multiple sbet files are available, the user is prompted to make a selection.
  • The Project Info data is a bit easier to read.
  • Validating BS & corrections within 360 degrees.
  • Added “1 Cmd” to Process Commands.
  • Enhanced LasMergeFiles.bat to allow for multiple files, rather than an entire folder, on command line.
  • Added a date/time to output when finished or interrupted.
  • Updated scan angle computation for +/- angles.
  • On restarting Ladybug Export, if the prior project was no longer available, the program could crash.
  • If a .top file is available it is converted upon first opening the project.
  • Added remainder of Hesai calibration files (40P, 64, 128).
  • Moved point of Snoopy*.top extraction and generation of lidar\*GeoEvents.txt.
  • Added “Climbs” and “Descents” to Project Info report.

Version 1.0.271, September 6, 2021

  • Added Open for output folder to making browsing point cloud data a little easier.
  • Fixed nuisance bug with HD32 and Puck getting confused on startup.
  • Removing some control point stats on File Reset.
  • Made search for sbet file smarter.
  • Fixing a number of ToolTips.
  • Column aligned data in ProjectInfo.

Version 1.0.270, August 25, 2021

  • Added ThinFiles.bat to setups for use in Process Commands.
  • Fixed miniVUX filters, again, for LHS & RHS.
  • During StripAlign Boresight, removing GeoRef\StripAlign folder and/or all of its contents before starting.
    • sbet.out was being left in StripAlign folder causing problems on subsequent runs.
  • Small bug in NCTech colorization with control.

Version 1.0.269, August 23, 2021

  • Merged Get Help with Help which is now a command button with a pull-down.
  • Added PPK to menu bar with pull-down options for PPK exe's, utils, and INS file selection.
  • To General Options added path options for PPK exe's (TerraDrone, IE, POSPac) with default option.
  • Fixed “well hidden” bug in control points that wouldn't allow a point to be deleted and re-added, sometimes.
  • Las output\*.kml files were not being generated for some INS (such as VectorNav).

Version 1.0.268, August 12, 2021

  • Added LasMerge to ProcessCommands. Output goes to merged\merged.laz
  • Fixed CUPDT bug with INS columns.
  • Added automatic extraction of Mark?Times in Snoopy folder.

Version 1.0.267, August 9, 2021

  • Fixed TP problem identifying units as meters (there was a change from (meters) to (m)).
  • In Exif (ImageEvents) using Z if elevation not present with lat, long.
  • Fixed Riegl number of returns exceeding las format (just introduced in last version).
  • In Image Events (EXIF), if Height column is missing or N/A from TP output, software will not continue and now displays a warning.

Version 1.0.266, July 27, 2021

  • Added ReadTopFile.exe. Freely distributable. Takes one argument - the Snoopy\*.top file.
    • It generates run-time INS and three kml files in Snoopy folder.
  • Even if the script used was not in scanlook.xml, if there are time corrections or calibrations for that sensor they will be used.
    • A red letter status message provides a warning to this affect.
  • The sta and INS files, upon using […] and cancel, no longer temporarily clear the field.
  • The XT16 now works completely.
  • The SN3+ systems now work.

Version 1.0.265, July 2, 2021

  • Additional internal changes for project startup.
  • Some filters (LHS, RHS) were broken in one of the recent posts. Now fixed.
  • Fixed exif tool to properly work with the TerraPOS INS file.
  • Tools::Process Commands is no longer modal and displays along with ScanLook.
  • Added P40P, P64, and P128 support (16 is untested).
  • Added Tools:M8 Analyzer to report the # distances and rotation reversals per M8 data file.
  • File::Project Info has been enhanced to handle multiple scanners and looks nicer.
  • Fixed minor bug with multi-line scanners, particularly > 32, not writing some points.
  • Added numerous valuable report items to the log file including echo count, point count by laser, etc.
  • M200/M300 filters work properly. Defaults general rotation to nadir to -90 degrees.
  • Added P*.xml files for slam to installation.

Version 1.0.264, June 4, 2021

  • Updated the VelodynePcap2scl installer to sort the Ultra and AlphaPuck data chronologically.
  • Process Commands wasn't finalizing grid selection choices upon using Preview .bat file.
    • Neither was Process Info for the main grid.
  • Radically changed the intensity setting logic for non Velodyne & Quanergy systems.
    • All scanners should now allow for a multiplier.
  • Added default XT32 calibration file.

Version 1.0.263, May 25, 2021

  • Slam processes like any other project.
  • The Tools:Process Commands would not always handle white space in the folder names properly.
  • Fixed new bug introduced when processing POSPac event files.
  • Added initial version of LIDARUSALas Tools.

Version 1.0.262, May 21, 2021

  • TerraPOS - fixed INTL. FT. Not sure where or when this went wrong.
  • Validating lasers to exclude and preview laser per scanner.
  • Velodyne HD32 systems in dual return mode would fail to load on full day scans due to the event file generated. This has been fixed.
  • Fixed proper initialization of a Surveyor 32 project. It would default to a Velodyne HD32.

Version 1.0.261, May 5, 2021

  • Very minor fix for Hesai projects on startup. (basically I wanted a Cinco de Mayo build!)

Version 1.0.260, May 4, 2021

  • Added CL90 calibration file.
  • Added StripAlign without requiring sbet.
  • TopoDOT interface nearly complete. Just the final XYZ and HRP values in the .lst file remain.
  • One more fix for the “yellow” caution of the Snoopy INS.

Version 1.0.259, April 13, 2021

  • Livox now supports individual laser ids (6).
  • Fixed WKT files to allow for white spaces in “PROJCS [”
  • In ProjectInfo put start/stop time of INS.
  • Using ScannerChannel attribute in las 1.4.
  • Updated PXT32 converter.
  • Added “ScanLook←” to Advanced Boresights to force reloading of calibration data.
  • Added Elevation to kml's.
  • Ladybug kml updated.
  • Updated Exif INS file formats to include an ever growing variety of file formats.

Version 1.0.258, March 26, 2021

  • Fixed more problems with empty or near empty (1 or 2 records) .scl files.
  • Added more *calibration* files to setup (PXT32, AlphaPuck, UltraPuck).
  • Added Livox converter to setup.
  • If no *Data*.<ext> files are found for selected scanner a message box will appear.
  • Fixed “.xml” file being created when starting LadybugExport. Very minor.
  • Added another filter, Thin By Rotation.
  • Fixed installation of control_point_search back to release (accidentally included a debug version).
  • Changed Hesai data files to use .hesai captured files.

Version 1.0. 257, March 17, 2021

  • Fixed several bugs in the dual M8 software. Nothing serious, just saves in re-loading between sensors.
    • One bug was more serious though. The include/exclude lasers would not work on the secondary sensor.
  • Ladybug: Fixed NCTech output for VisionLidar files (H=H+90, R=P, P=90-R relative to Ladybug)
  • Continuing with the merger of continuous patches in matching and control, the solution was further refined.
  • Exif Export (not really named right) now supports GNSS-only files for PPK.
    • Event file contains no orientation and is at the time of capture (not 200Hz).
  • Added Pause (secs) to General Parameters for some DOS command windows. Defaults to 0 or no pause.
  • Added StripAlign Flights to run StripAlign on selected folder.
  • Added StripAlign arguments to General Parameters.
  • GPS-only PPK for camera with epochs fixed spaces in full filename and use lat, long, elev.
    • lat, long, elev can follow the xyz coordinates in trajectory file (no orientations).

Version 1.0.256

  • StripAlign
    • Add exit criteria to stop iterating when corrections are so small.
  • Match Overlap - added Red boxes for caution if filters or segments enabled.
  • Fixed control/matching bug when two segments are found but are very close together. Now they are merged as one.
  • Fixed bug with Quanergy data crossing the GPS week boundary (604800 seconds rolling back to 0).
  • Fixed bug in many scanner translations when data files are empty (e.g. <Scanner>Data_1.scl).
  • Added <ProjectName>.snp to project folder that is associated to the ScanLook software to allow double clicking.
  • If using the .top file, the background of the INS text field is now yellow.
  • In the Ladybug boresight tool, search continues for pgr files created outside of ScanLook (just the *.pgr extension).
  • Moved the Angle (min/max) filters to the Advanced Filters dialog.
  • NCTech posted a fix for imagery collected using FW 2.6.1 in distance mode. The fix adds a column for utctime (2nd column) to give more accurate timing.

Version 1.0.255

  • Added warning if INS event rate is incorrect.
  • Fixed NumReturns and ReturnNum in LAS file tags on points.
    • Had previously interpreted NumReturns as the # possible from the scanner, not actual recorded (the latter can always be computed and is redundant information).
  • Fixed bug in Velodyne multiple returns giving duplicate GPS time tag.
  • If bad pcap file packet size, report it.
  • Added menu system.
    • File (Reset Files, Backups).
    • Options (Advanced Parameters, Backup Options, Edit Parameters, and Load/Save Defaults).
    • Tools (CUPDT, Match Overlap, Show Batch command, Process Commands).
    • Programs (simple common Windows tools).
    • Help (Wiki, Training portal, Chat, eTickets, downloads, release notes)
  • Added super tiny time correction for the Riegl VUX systems.
  • Allow for control dialog to display even if no control.txt exists.
  • Added smarter search for sta files.
  • Removed Strongest option for Velodyne replaced with All, First, Last.
  • Added extra calibration parameter for scale if necessary.
  • Added ZF convert and Riegl Convert as a batch commands.
  • Intensity filters properly use “!<lo>-<hi>”. It wasn't completely working before. Do not mix ! for exclusion with a line for inclusion. In other words, only exclude or include, but not both.
  • Added option to output each laser in its own las/laz file (already had it for text).
  • Selecting entire field on text entry boxes by default when they get focus (as expected in Windows).
  • Updated Options dialog for Riegl MTA options.
  • Updated Options dialog for Z+F filter options.
  • Added more batch scripts for processing Riegl and Z+F raw data files.
  • Moved output.xml, output.kml to an “output” folder to reduce clutter.
  • Added RED CAUTION box when running control IF main filters are enabled.
  • Wow, found some setup dates with -2017 and changed them to 2019.
  • Added a user specific folder depth search parameter. Defaulting to 10. This will only be an issue if you have a lot of folders and files under your project. If you do, you should set this to 2 or 3. You can manually edit this in your <UserName>\AppData\Roaming\ScanLook.xml file by adding in the Options section FolderDepthToSearch.
  • The base output filename for Riegl scans would go to Riegl UNLESS you hit Reset Files, Graphics, or Convert which would then use miniVUX, VUXLR, or VUX as appropriate. Now it uses the later by default and not Riegl.
  • Added a Project Info box with some key information nicely assembled. It is under the File menu.
  • Added export of corrected scanner trajectory with boresight AND control/tie corrections.
  • Made control point search “smarter” - I hope.
  • Changed progress from display of current event to current time and h:m:s of scan data remaining.
  • Added ability to notify clients by scanner with messages.
  • Added a General Options dialog for a few necessary options (linear units).
  • Updated Graphics to be able to load in the Point Cloud index files for more than just Velodyne.
  • Added export to RPH and Quaternions for Ladybug*Extended*txt files to support more 3rd party software.
  • Added Optech CL-90 processing!!!
  • Added PhaseOne, Sentera, and Smoother interfaces to Options menu.
  • Added more control point search and find parameters to Options::General Options.
  • In General Options added a Ladybug Folder option in case it was not in the normal location in the project itself.
  • Added a “Feathering” parameter to General Options for the Smoother.
  • When changing a project, the command buttons are temporarily disabled until the change is complete.
  • Multiple Riegl rxp files can now be processed properly.
  • Added some improvements for sensors working with TimeOfDay (ToD) instead of TimeOfWeek (ToW).
  • Added some additional Quanergy M8 calibration parameters.
  • Fixed minor nuisance bug where Riegl files (mini or VUX) would sometimes default as Riegl instead of miniVUX, VUX or VUXLR.
  • Riegl rxp file converter is sensitive to spaces in the path. Found a fix for this.
  • On Advanced Boresight, the “→ScanLook” command now creates a tar file for updating the sensor settings.
  • Ladybug boresight tools are delivered with Ladybug setup files.
  • When switching INS files (.top to actual INS, etc.) it wouldn't necessarily catch the units change. Now it does.
  • Allow users to change LAS file resolution. Default remains at 0.001.
  • In Velodyne processing, the “Power” mode would duplicate points (per the packet structure). The duplicate points are now removed.
  • Added check for IE exported INS files to verify proper “Axes” selection as “Axes: x-right, y-forward, z-up”.
  • Added control point check to see if the GCP's are within the area or possibly swapped XY.
  • Updated Cepton processing to the latest version (SORA and VISTA).
  • If gps-time*.csv has 0 positional info, and there is a Snoopy/*.top file, a new *gps-time*2.csv will be created so we can still get the desired kml file.
  • Fixed Graphics crash when using Riegl and no SDC conversion has been done yet.
  • Added more IE export checks for proper export (IMU to GNSS and Body To Sensor).
  • Added check for corrupt end-of-file in Riegl data and just backed up to last good data.
  • Added on/off yellow X-measurement symbol in control measurement dialog.
  • The World X-form used in point cloud generation is now carried over to the ladybug processing.
  • If the Riegl sdc file is smaller than the rxp file, the problem is flagged.
  • Added another IE export check to validate that OPK values are legitimate.
  • Added a Debug option to the help menu that creates a ProjectDebug.log file. This helps us debug customer problems.
  • Added ScanLook LB, Ladybug Boresight Measurement and Calculation options to the Tools menu. This makes the entire LB process a bit easier, especially the boresight calculation.
  • Fixed vZ control point threshold check (wasn't using Absolute value for magnitude).
  • When clicking on a control point measurement outside of any lidar points, the Z value is computed from the entire data set rather than returning 0's.
  • Added Add-in manager to Programs menu.
  • To File menu added Project Notes.
  • Even if the Stationary Filter was disabled, it would still be enforced at 0.005 units. This has now been removed so the data can be piled up (some programs apparently cannot deal with a data discontinuity in time even though there is no discontinuity in coverage).
  • Added option to generate square patches (still recommend the default of circles) for control and strip matching.
  • For all Velodyne HD systems, if packets is not 9, it forces it back to 9. This could be a problem if somebody reconfigured their system to parameters other than the default.
  • Added Ouster 16, 32, 64, and 128 and CL-360 scanners.
  • Updated ZF-converter to handled scans that are paused or stopped and resumed.
  • If the Time Correction on the Advanced Parameters dialog changes, then Reset Files is automatically invoked.
  • Fixed NovAtelConvert.exe path for TerraPOS setups. Now checks all conditions for path.
  • Expanded use to 128-lasers for Ouster and Velodyne.
  • Fixed resize of Refresh button on Process Commands dialog.
  • Smoother now defaults to current project.
  • Smoother no longer pro-rates feathering distance but uses provided distance.
  • Added more ZF-convert scripts (for defaults and no filters).
  • Added Fix Rinex option to Process Commands scripts.
  • Computing ScanDirection for LAS output of CL-90 and miniVUX-1DL. Updated all similar flags in LAS.
  • Added point formats 6 & 7 of LAS definition and las format 1.4. WKT not yet implemented for coordinate system.
  • Dramatically improved speed of LAS file writes.
  • If recording Riegl as rxp files and converting to sdc, reading model from sdc file.
  • Fixed potential problem with folders contains &^, in folder name. Folders such as C:\A&B\… would cause some commands like control point measurement to fail.
  • A critical angle function could cause problems with default boresights.
  • Fixed GpsTime=0 data records being written after improving write speeds dramatically.
  • Many updates to incorporate the XY tie point matching.
  • Changed many of the Setup files to run silently. Only FARO couldn't be hidden.
  • Added fore/Aft distance filters.
  • Updated control/tie correction for better distance interpolation.
  • Reading Riegl Model directly from SDC (format is undocumented).
  • Added “ExtraBytes” for one client (scan angle, local XYZ) to be written to LAS files. Got rid of Alt RGB.
  • Updating ScanAngle calculation. Trying to make them all relative to nadir.
  • Hiding sta file if not necessary.
  • Updated control correction to better interpolate over distance independent of event step size.
  • Applying spatial proximity filters AFTER applying control/tie corrections.
  • If more than 5 returns but only 5 returns allowed by format, using 1 to 4 and then the last return.
  • Excluding Ties and Control folders from all file searches (to speed things up).
  • In Stop-and-go (pause/resume) scanning with Velodyne, the EndingTime on some 'breaks' would be off by one event. This is just used for a lookup for convenience so no geometric issues.
  • Breaking las files to separate files on pause-resume breaks
  • Added user parameter for Scanner Rotation to Nadir. This is just in case the internal solution is somehow incorrect.
  • Added Opt2Scl (Optech to ScanLook) conversion.
  • Added horizontal tie point correction for streetview scanning.
  • Modified some Yes/No/Cancel user queries to use a better option dialog.
  • Fixed command line to once again work properly.
  • Added automatic creation of an EXIF friendly data file to Ladybug.
  • Fixed Cumulative Distance calculation in stop-and-go scenarios.
  • Added option to disable Nag screens (are you sure, etc.?).
  • If a raw data file is missing the user is warned. E.g. if VelodyneData_2.pcap is missing.
  • The Distance calculation in the Graphics tool was incorrect for accumulated, multiple leg measurements.
  • Added the NCTech 360 iStar camera boresight and colorization.
  • Added General Options to include Output Options: Distance Break (10) and Time Gap (1).
    • Distance Breaks closes one las file and opens a new one if the distance between lines is greater than the given distance.
    • Time Gap does the same thing if the time difference is greater than the given time in seconds.
    • Both can be enabled or disabled.
  • Added several more scanners.
  • Tools menu. Added Image Events to generate metadata file and exif info for UAV imagery.
  • Added more event files for RPH (roll pitch heading), Quaternions, and Lat, Long, elev, and more.
  • Added minimum speed filter.
  • ZF graphics now only show where scanner was recording, not entire trajectory.
  • In the File Info dialog, more parameters are displayed such as serial numbers, etc.
  • Multi-threaded processes can now self-determine best course of action for CPU usage.
  • When using StripAlign, strips are tested to ensure they do not overlap by time.
  • Ladybug Export uses the tar file correctly.
  • Added sensor specific timing offset in ScanLook.xml file.
  • Stop (processing) button glitch being disabled when using Convert→Graphics→Cancel Graphics is fixed.
  • Ladybug and NCTech event files are output with a single space column delimiter to ease the pain in other programs.
  • APX20 LHS/RHS filter wasn't working properly.
  • Fixed differing output units on all scanners except FARO, Velodyne, and Quanergy (they were working fine).
  • Ladybug
    • Added time interval parameter for End Points jump criteria. Previously hardcoded to 1.
    • Disable time criteria option for distance only captures.
  • Added ScanDirection filter (for CL90 and miniVUX-DL).
  • If processing Velodyne, new stationary filter would chop the data a little odd giving a banding look. It was ok but looked funny.

Versions prior to 1.0.255 have been removed.

scanlook-pc-release-notes.txt · Last modified: 2021/10/18 16:10 by jeff.fagerman

Bitnami