User Tools

Site Tools


scanlook-pc-release-notes

ScanLook PC (Point Cloud) Release Notes

Version 1.0.2##

TBD, 2021 <We skipped a few Release Note updates, about 60!>

  1. Added warning if INS event rate is incorrect.
  2. Fixed NumReturns and ReturnNum in LAS file tags on points.
    1. Had previously interpreted NumReturns as the # possible from the scanner, not actual recorded (the latter can always be computed and is redundant information).
  3. Fixed bug in Velodyne multiple returns giving duplicate GPS time tag.
  4. If bad pcap file packet size, report it.
  5. Added menu system.
    1. File (Reset Files, Backups).
    2. Options (Advanced Parameters, Backup Options, Edit Parameters, and Load/Save Defaults).
    3. Tools (CUPDT, Match Overlap, Show Batch command, Process Commands).
    4. Programs (simple common Windows tools).
    5. Help (Wiki, Training portal, Chat, eTickets, downloads, release notes)
  6. Added super tiny time correction for the Riegl VUX systems.
  7. Allow for control dialog to display even if no control.txt exists.
  8. Added smarter search for sta files.
  9. Removed Strongest option for Velodyne replaced with All, First, Last.
  10. Added extra calibration parameter for scale if necessary.
  11. Added ZF convert and Riegl Convert as a batch commands.
  12. Intensity filters properly use “!<lo>-<hi>”. It wasn't completely working before. Do not mix ! for exclusion with a line for inclusion. In other words, only exclude or include, but not both.
  13. Added option to output each laser in its own las/laz file (already had it for text).
  14. Selecting entire field on text entry boxes by default when they get focus (as expected in Windows).
  15. Updated Options dialog for Riegl MTA options.
  16. Updated Options dialog for Z+F filter options.
  17. Added more batch scripts for processing Riegl and Z+F raw data files.
  18. Moved output.xml, output.kml to an “output” folder to reduce clutter.
  19. Added RED CAUTION box when running control IF main filters are enabled.
  20. Wow, found some setup dates with -2017 and changed them to 2019.
  21. Added a user specific folder depth search parameter. Defaulting to 10. This will only be an issue if you have a lot of folders and files under your project. If you do, you should set this to 2 or 3. You can manually edit this in your <UserName>\AppData\Roaming\ScanLook.xml file by adding in the Options section FolderDepthToSearch.
  22. The base output filename for Riegl scans would go to Riegl UNLESS you hit Reset Files, Graphics, or Convert which would then use miniVUX, VUXLR, or VUX as appropriate. Now it uses the later by default and not Riegl.
  23. Added a Project Info box with some key information nicely assembled. It is under the File menu.
  24. Added export of corrected scanner trajectory with boresight AND control/tie corrections.
  25. Made control point search “smarter” - I hope.
  26. Changed progress from display of current event to current time and h:m:s of scan data remaining.
  27. Added ability to notify clients by scanner with messages.
  28. Added a General Options dialog for a few necessary options (linear units).
  29. Updated Graphics to be able to load in the Point Cloud index files for more than just Velodyne.
  30. Added export to RPH and Quaternions for Ladybug*Extended*txt files to support more 3rd party software.
  31. Added Optech CL-90 processing!!!
  32. Added PhaseOne, Sentera, and Smoother interfaces to Options menu.
  33. Added more control point search and find parameters to Options::General Options.
  34. In General Options added a Ladybug Folder option in case it was not in the normal location in the project itself.
  35. Added a “Feathering” parameter to General Options for the Smoother.
  36. When changing a project, the command buttons are temporarily disabled until the change is complete.
  37. Multiple Riegl rxp files can now be processed properly.
  38. Added some improvements for sensors working with TimeOfDay (ToD) instead of TimeOfWeek (ToW).
  39. Added some additional Quanergy M8 calibration parameters.
  40. Fixed minor nuisance bug where Riegl files (mini or VUX) would sometimes default as Riegl instead of miniVUX, VUX or VUXLR.
  41. Riegl rxp file converter is sensitive to spaces in the path. Found a fix for this.
  42. On Advanced Boresight, the “→ScanLook” command now creates a tar file for updating the sensor settings.
  43. Ladybug boresight tools are delivered with Ladybug setup files.
  44. When switching INS files (.top to actual INS, etc.) it wouldn't necessarily catch the units change. Now it does.
  45. Allow users to change LAS file resolution. Default remains at 0.001.
  46. In Velodyne processing, the “Power” mode would duplicate points (per the packet structure). The duplicate points are now removed.
  47. Added check for IE exported INS files to verify proper “Axes” selection as “Axes: x-right, y-forward, z-up”.
  48. Added control point check to see if the GCP's are within the area or possibly swapped XY.
  49. Updated Cepton processing to the latest version (SORA and VISTA).
  50. If gps-time*.csv has 0 positional info, and there is a Snoopy/*.top file, a new *gps-time*2.csv will be created so we can still get the desired kml file.
  51. Fixed Graphics crash when using Riegl and no SDC conversion has been done yet.
  52. Added more IE export checks for proper export (IMU to GNSS and Body To Sensor).
  53. Added check for corrupt end-of-file in Riegl data and just backed up to last good data.
  54. Added on/off yellow X-measurement symbol in control measurement dialog.
  55. The World X-form used in point cloud generation is now carried over to the ladybug processing.
  56. If the Riegl sdc file is smaller than the rxp file, the problem is flagged.
  57. Added another IE export check to validate that OPK values are legitimate.
  58. Added a Debug option to the help menu that creates a ProjectDebug.log file. This helps us debug customer problems.
  59. Added ScanLook LB, Ladybug Boresight Measurement and Calculation options to the Tools menu. This makes the entire LB process a bit easier, especially the boresight calculation.
  60. Fixed vZ control point threshold check (wasn't using Absolute value for magnitude).
  61. When clicking on a control point measurement outside of any lidar points, the Z value is computed from the entire data set rather than returning 0's.
  62. Added Add-in manager to Programs menu.
  63. To File menu added Project Notes.
  64. Even if the Stationary Filter was disabled, it would still be enforced at 0.005 units. This has now been removed so the data can be piled up (some programs apparently cannot deal with a data discontinuity in time even though there is no discontinuity in coverage).
  65. Added option to generate square patches (still recommend the default of circles) for control and strip matching.
  66. For all Velodyne HD systems, if packets is not 9, it forces it back to 9. This could be a problem if somebody reconfigured their system to parameters other than the default.
  67. Added Ouster 16, 32, 64, and 128 and CL-360 scanners.
  68. Updated ZF-converter to handled scans that are paused or stopped and resumed.
  69. If the Time Correction on the Advanced Parameters dialog changes, then Reset Files is automatically invoked.
  70. Fixed NovAtelConvert.exe path for TerraPOS setups. Now checks all conditions for path.
  71. Expanded use to 128-lasers for Ouster and Velodyne.
  72. Fixed resize of Refresh button on Process Commands dialog.
  73. Smoother now defaults to current project.
  74. Smoother no longer pro-rates feathering distance but uses provided distance.
  75. Added more ZF-convert scripts (for defaults and no filters).
  76. Added Fix Rinex option to Process Commands scripts.
  77. Computing ScanDirection for LAS output of CL-90 and miniVUX-1DL. Updated all similar flags in LAS.
  78. Added point formats 6 & 7 of LAS definition and las format 1.4. WKT not yet implemented for coordinate system.
  79. Dramatically improved speed of LAS file writes.
  80. If recording Riegl as rxp files and converting to sdc, reading model from sdc file.
  81. Fixed potential problem with folders contains &^, in folder name. Folders such as C:\A&B\… would cause some commands like control point measurement to fail.
  82. A critical angle function could cause problems with default boresights.
  83. Fixed GpsTime=0 data records being written after improving write speeds dramatically.
  84. Many updates to incorporate the XY tie point matching.
  85. Changed many of the Setup files to run silently. Only FARO couldn't be hidden.
  86. Added fore/Aft distance filters.
  87. Updated control/tie correction for better distance interpolation.
  88. Reading Riegl Model directly from SDC (format is undocumented).
  89. Added “ExtraBytes” for one client (scan angle, local XYZ) to be written to LAS files. Got rid of Alt RGB.
  90. Updating ScanAngle calculation. Trying to make them all relative to nadir.
  91. Hiding sta file if not necessary.
  92. Updated control correction to better interpolate over distance independent of event step size.
  93. Applying spatial proximity filters AFTER applying control/tie corrections.
  94. If more than 5 returns but only 5 returns allowed by format, using 1 to 4 and then the last return.
  95. Excluding Ties and Control folders from all file searches (to speed things up).
  96. In Stop-and-go (pause/resume) scanning with Velodyne, the EndingTime on some 'breaks' would be off by one event. This is just used for a lookup for convenience so no geometric issues.
  97. Breaking las files to separate files on pause-resume breaks
  98. Added user parameter for Scanner Rotation to Nadir. This is just in case the internal solution is somehow incorrect.
  99. Added Opt2Scl (Optech to ScanLook) conversion.
  100. Added horizontal tie point correction for streetview scanning.
  101. Modified some Yes/No/Cancel user queries to use a better option dialog.
  102. Fixed command line to once again work properly.
  103. Added automatic creation of an EXIF friendly data file to Ladybug.
  104. Fixed Cumulative Distance calculation in stop-and-go scenarios.
  105. Added option to disable Nag screens (are you sure, etc.?).
  106. If a raw data file is missing the user is warned. E.g. if VelodyneData_2.pcap is missing.
  107. The Distance calculation in the Graphics tool was incorrect for accumulated, multiple leg measurements.
  108. Added the NCTech 360 iStar camera boresight and colorization.
  109. Added General Options to include Output Options: Distance Break (10) and Time Gap (1).
    1. Distance Breaks closes one las file and opens a new one if the distance between lines is greater than the given distance.
    2. Time Gap does the same thing if the time difference is greater than the given time in seconds.
    3. Both can be enabled or disabled.
  110. Added several more scanners.
  111. Tools menu. Added Image Events to generate metadata file and exif info for UAV imagery.
  112. Added more event files for RPH (roll pitch heading), Quaternions, and Lat, Long, elev, and more.
  113. Added minimum speed filter.
  114. ZF graphics now only show where scanner was recording, not entire trajectory.
  115. In the File Info dialog, more parameters are displayed such as serial numbers, etc.
  116. Multi-threaded processes can now self-determine best course of action for CPU usage.
  117. When using StripAlign, strips are tested to ensure they do not overlap by time.
  118. Ladybug Export uses the tar file correctly.
  119. Added sensor specific timing offset in ScanLook.xml file.
  120. Stop (processing) button glitch being disabled when using Convert→Graphics→Cancel Graphics is fixed.
  121. Ladybug and NCTech event files are output with a single space column delimiter to ease the pain in other programs.
  122. APX20 LHS/RHS filter wasn't working properly.
  123. Fixed differing output units on all scanners except FARO, Velodyne, and Quanergy (they were working fine).
  124. Ladybug
    1. Added time interval parameter for End Points jump criteria. Previously hardcoded to 1.
    2. Disable time criteria option for distance only captures.
  125. Added ScanDirection filter (for CL90 and miniVUX-DL).
  126. If processing Velodyne, new stationary filter would chop the data a little odd giving a banding look. It was ok but looked funny.
  127. <End build 255>
  128. StripAlign
    1. Add exit criteria to stop iterating when corrections are so small.
  129. Match Overlap - added Red boxes for caution if filters or segments enabled.
  130. Fixed control/matching bug when two segments are found but are very close together. Now they are merged as one.
  131. Fixed bug with Quanergy data crossing the GPS week boundary (604800 seconds rolling back to 0).
  132. Fixed bug in many scanner translations when data files are empty (e.g. <Scanner>Data_1.scl).
  133. Added <ProjectName>.snp to project folder that is associated to the ScanLook software to allow double clicking.
  134. If using the .top file, the background of the INS text field is now yellow.
  135. In the Ladybug boresight tool, search continues for pgr files created outside of ScanLook (just the *.pgr extension).
  136. Moved the Angle (min/max) filters to the Advanced Filters dialog.
  137. NCTech posted a fix for imagery collected using FW 2.6.1 in distance mode. The fix adds a column for utctime (2nd column) to give more accurate timing.
  138. <End of build 256>
  139. Fixed several bugs in the dual M8 software. Nothing serious, just saves in re-loading between sensors.
    1. One bug was more serious though. The include/exclude lasers would not work on the secondary sensor.
  140. Ladybug: Fixed NCTech output for VisionLidar files (H=H+90, R=P, P=90-R relative to Ladybug)
  141. Continuing with the merger of continuous patches in matching and control, the solution was further refined.
  142. Exif Export (not really named right) now supports GNSS-only files for PPK.
    1. Event file contains no orientation and is at the time of capture (not 200Hz).
  143. Added Pause (secs) to General Parameters for some DOS command windows. Defaults to 0 or no pause.
  144. Added StripAlign Flights to run StripAlign on selected folder.
  145. Added StripAlign arguments to General Parameters.
  146. GPS-only PPK for camera with epochs fixed spaces in full filename and use lat, long, elev.
    1. lat, long, elev can follow the xyz coordinates in trajectory file (no orientations).
  147. <End of build 257 (March 17, 2021)>
  148. Fixed more problems with empty or near empty (1 or 2 records) .scl files.
  149. Added more *calibration* files to setup (PXT32, AlphaPuck, UltraPuck).
  150. Added Livox converter to setup.
  151. If no *Data*.<ext> files are found for selected scanner a message box will appear.
  152. Fixed “.xml” file being created when starting LadybugExport. Very minor.
  153. Added another filter, Thin By Rotation.
  154. Fixed installation of control_point_search back to release (accidentally included a debug version).
  155. Changed Hesai data files to use .hesai captured files.
  156. <End of build 258 (March 26, 2021)>
  157. Livox now supports individual laser ids (6).
  158. Fixed WKT files to allow for white spaces in “PROJCS [”
  159. In ProjectInfo put start/stop time of INS.
  160. Using ScannerChannel attribute in las 1.4.
  161. Updated PXT32 converter.
  162. Added “ScanLook←” to Advanced Boresights to force reloading of calibration data.
  163. Added Elevation to kml's.
  164. Ladybug kml updated.
  165. Updated Exif INS file formats to include an ever growing variety of file formats.
  166. <End of build 259 (April 13, 2021)>
  167. Added CL90 calibration file.
  168. Added StripAlign without requiring sbet.
  169. TopoDOT interface nearly complete. Just the final XYZ and HRP values in the .lst file remain.
  170. One more fix for the “yellow” caution of the Snoopy INS.
  171. <End of build 260 (May 4, 2021)>
  172. Very minor fix for Hesai projects on startup. (basically I wanted a Cinco de Mayo build!)
  173. <End of build 261 (May 5, 2021)>
  174. TerraPOS - fixed INTL. FT. Not sure where or when this went wrong.
  175. Validating lasers to exclude and preview laser per scanner.
  176. Velodyne HD32 systems in dual return mode would fail to load on full day scans due to the event file generated. This has been fixed.
  177. Fixed proper initialization of a Surveyor 32 project. It would default to a Velodyne HD32.
  178. <End of build 262 (May 21, 2021)>
  179. Slam processes like any other project.
  180. The Tools:Process Commands would not always handle white space in the folder names properly.
  181. Fixed new bug introduced when processing POSPac event files.
  182. Added initial version of LIDARUSALas Tools.
  183. <End of build 263 (May 25, 2021)>
  184. Updated the VelodynePcap2scl installer to sort the Ultra and AlphaPuck data chronologically.
  185. Process Commands wasn't finalizing grid selection choices upon using Preview .bat file.
    1. Neither was Process Info for the main grid.
  186. Radically changed the intensity setting logic for non Velodyne & Quanergy systems.
    1. All scanners should now allow for a multiplier.
  187. Added default XT32 calibration file.
  188. <End of build 264 (June 4, 2021)>
  189. Additional internal changes for project startup.
  190. Some filters (LHS, RHS) were broken in one of the recent posts. Now fixed.
  191. Fixed exif tool to properly work with the TerraPOS INS file.
  192. Tools::Process Commands is no longer modal and displays along with ScanLook.
  193. Added P40P, P64, and P128 support (16 is untested).
  194. Added Tools:M8 Analyzer to report the # distances and rotation reversals per M8 data file.
  195. File::Project Info has been enhanced to handle multiple scanners and looks nicer.
  196. Fixed minor bug with multi-line scanners, particularly > 32, not writing some points.
  197. Added numerous valuable report items to the log file including echo count, point count by laser, etc.
  198. M200/M300 filters work properly. Defaults general rotation to nadir to -90 degrees.
  199. Added P*.xml files for slam to installation.
  200. <End of build 265 (July 2, 2021)>

Version 1.0.135

Enhanced Interrupt operation.

After each file is completed it is written as the last Interrupt.
On Resume if Manually interrupted it asks you if you want to keep last
  partial file.
  

Added Segment/folder id to FileSourceId in LAS header.

Version 1.0.134

Version 1.0.122

  1. Leap Second fix particularly affecting the Velodyne data.

Version 1.0.119

  1. Added some messages when starting colorizing.
  2. Added Trimble Applanix POS input.
  3. Changed trajectory thinning to be greedy (get closest match less than filter settings).
  4. Added Profile (streetview/aerial) to Control Dialog.
  5. Asundry other minor items.

Version 1.0.118

  1. Some very minor fixes.

Version 1.0.117

  1. Fixed bug with first installation on a system creating 1kb las files. It wasn't creating a user folder for the calibration file.
  2. Added Ladybug offset logic for ladybug events and including image paths in event file (Ladybug*Extended.txt).
  3. Added one time prompt for Customer name.
  4. Added initial Quanergy stuff.
  5. Creating Velodyne*.kml files in pcap folder. This is handy to see exactly where the scanner was on and off, not just where the INS was tracking.
scanlook-pc-release-notes.txt · Last modified: 2021/07/02 15:09 by jeff.fagerman

Bitnami