User Tools

Site Tools


scanlook-pc-release-notes

This is an old revision of the document!


ScanLook PC (Point Cloud) Release Notes

Version 1.0.19X

TBD, 2019 <We skipped a few Release Note updates, about 60!>

  1. Added warning if INS event rate is incorrect.
  2. Fixed NumReturns and ReturnNum in LAS file tags on points.
    1. Had previously interpreted NumReturns as the # possible from the scanner, not actual recorded (the latter can always be computed and is redundant information).
  3. Fixed bug in Velodyne multiple returns giving duplicate GPS time tag.
  4. If bad pcap file packet size, report it.
  5. Added menu system.
    1. File (Reset Files, Backups).
    2. Options (Advanced Parameters, Backup Options, Edit Parameters, and Load/Save Defaults).
    3. Tools (CUPDT, Match Overlap, Show Batch command, Process Commands).
    4. Programs (simple common Windows tools).
    5. Help (Wiki, Training portal, Chat, eTickets, downloads, release notes)
  6. Added super tiny time correction for the Riegl VUX systems.
  7. Allow for control dialog to display even if no control.txt exists.
  8. Added smarter search for sta files.
  9. Removed Strongest option for Velodyne replaced with All, First, Last.
  10. Added extra calibration parameter for scale if necessary.
  11. Added ZF convert and Riegl Convert as a batch commands.
  12. Intensity filters properly use “!<lo>-<hi>”. It wasn't completely working before. Do not mix ! for exclusion with a line for inclusion. In other words, only exclude or include, but not both.
  13. Added option to output each laser in its own las/laz file (already had it for text).
  14. Selecting entire field on text entry boxes by default when they get focus (as expected in Windows).
  15. Updated Options dialog for Riegl MTA options.
  16. Updated Options dialog for Z+F filter options.
  17. Added more batch scripts for processing Riegl and Z+F raw data files.
  18. Moved output.xml, output.kml to an “output” folder to reduce clutter.
  19. Added RED CAUTION box when running control IF main filters are enabled.
  20. Wow, found some setup dates with -2017 and changed them to 2019.
  21. Added a user specific folder depth search parameter. Defaulting to 10. This will only be an issue if you have a lot of folders and files under your project. If you do, you should set this to 2 or 3. You can manually edit this in your <UserName>\AppData\Roaming\ScanLook.xml file by adding in the Options section FolderDepthToSearch.
  22. The base output filename for Riegl scans would go to Riegl UNLESS you hit Reset Files, Graphics, or Convert which would then use miniVUX, VUXLR, or VUX as appropriate. Now it uses the later by default and not Riegl.
  23. Added a Project Info box with some key information nicely assembled. It is under the File menu.
  24. Added export of corrected scanner trajectory with boresight AND control/tie corrections.
  25. Made control point search “smarter” - I hope.
  26. Changed progress from display of current event to current time and h:m:s of scan data remaining.
  27. Added ability to notify clients by scanner with messages.
  28. Added a General Options dialog for a few necessary options (linear units).
  29. Updated Graphics to be able to load in the Point Cloud index files for more than just Velodyne.
  30. Added export to RPH and Quaternions for Ladybug*Extended*txt files to support more 3rd party software.
  31. Added Optech CL-90 processing!!!
  32. Added PhaseOne, Sentera, and Smoother interfaces to Options menu.
  33. Added more control point search and find parameters to Options::General Options.
  34. In General Options added a Ladybug Folder option in case it was not in the normal location in the project itself.
  35. Added a “Feathering” parameter to General Options for the Smoother.
  36. When changing a project, the command buttons are temporarily disabled until the change is complete.
  37. Multiple Riegl rxp files can now be processed properly.
  38. Added some improvements for sensors working with TimeOfDay (ToD) instead of TimeOfWeek (ToW).
  39. Added some additional Quanergy M8 calibration parameters.
  40. Fixed minor nuisance bug where Riegl files (mini or VUX) would sometimes default as Riegl instead of miniVUX, VUX or VUXLR.
  41. Riegl rxp file converter is sensitive to spaces in the path. Found a fix for this.
  42. On Advanced Boresight, the “→ScanLook” command now creates a tar file for updating the sensor settings.
  43. Ladybug boresight tools are delivered with Ladybug setup files.
  44. When switching INS files (.top to actual INS, etc.) it wouldn't necessarily catch the units change. Now it does.
  45. Allow users to change LAS file resolution. Default remains at 0.001.
  46. In Velodyne processing, the “Power” mode would duplicate points (per the packet structure). The duplicate points are now removed.
  47. Added check for IE exported INS files to verify proper “Axes” selection as “Axes: x-right, y-forward, z-up”.
  48. Added control point check to see if the GCP's are within the area or possibly swapped XY.
  49. Updated Cepton processing to the latest version (SORA and VISTA).
  50. If gps-time*.csv has 0 positional info, and there is a Snoopy/*.top file, a new *gps-time*2.csv will be created so we can still get the desired kml file.
  51. Fixed Graphics crash when using Riegl and no SDC conversion has been done yet.
  52. Added more IE export checks for proper export (IMU to GNSS and Body To Sensor).
  53. Added check for corrupt end-of-file in Riegl data and just backed up to last good data.
  54. Added on/off yellow X-measurement symbol in control measurement dialog.
  55. The World X-form used in point cloud generation is now carried over to the ladybug processing.
  56. If the Riegl sdc file is smaller than the rxp file, the problem is flagged.
  57. Added another IE export check to validate that OPK values are legitimate.
  58. Added a Debug option to the help menu that creates a ProjectDebug.log file. This helps us debug customer problems.
  59. Added ScanLook LB, Ladybug Boresight Measurement and Calculation options to the Tools menu. This makes the entire LB process a bit easier, especially the boresight calculation.
  60. Fixed vZ control point threshold check (wasn't using Absolute value for magnitude).
  61. When clicking on a control point measurement outside of any lidar points, the Z value is computed from the entire data set rather than returning 0's.
  62. Added Add-in manager to Programs menu.
  63. To File menu added Project Notes.
  64. Even if the Stationary Filter was disabled, it would still be enforced at 0.005 units. This has now been removed so the data can be piled up (some programs apparently cannot deal with a data discontinuity in time even though there is no discontinuity in coverage).
  65. Added option to generate square patches (still recommend the default of circles) for control and strip matching.
  66. For all Velodyne HD systems, if packets is not 9, it forces it back to 9. This could be a problem if somebody reconfigured their system to parameters other than the default.
  67. Added Ouster 16, 32, 64, and 128 and CL-360 scanners.
  68. Updated ZF-converter to handled scans that are paused or stopped and resumed.
  69. If the Time Correction on the Advanced Parameters dialog changes, then Reset Files is automatically invoked.
  70. Fixed NovAtelConvert.exe path for TerraPOS setups. Now checks all conditions for path.
  71. Expanded use to 128-lasers for Ouster and Velodyne.
  72. Fixed resize of Refresh button on Process Commands dialog.
  73. Smoother now defaults to current project.
  74. Smoother no longer pro-rates feathering distance but uses provided distance.
  75. Added more ZF-convert scripts (for defaults and no filters).
  76. Added Fix Rinex option to Process Commands scripts.
  77. Computing ScanDirection for LAS output of CL-90 and miniVUX-1DL. Updated all similar flags in LAS.
  78. Added point formats 6 & 7 of LAS definition and las format 1.4. WKT not yet implemented for coordinate system.
  79. Dramatically improved speed of LAS file writes.
  80. If recording Riegl as rxp files and converting to sdc, reading model from sdc file.
  81. Fixed potential problem with folders contains &^, in folder name. Folders such as C:\A&B\… would cause some commands like control point measurement to fail.
  82. A critical angle function could cause problems with default boresights.
  83. Fixed GpsTime=0 data records being written after improving write speeds dramatically.
  84. Many updates to incorporate the XY tie point matching.
  85. Changed many of the Setup files to run silently. Only FARO couldn't be hidden.
  86. Added fore/Aft distance filters.
  87. Updated control/tie correction for better distance interpolation.
  88. Reading Riegl Model directly from SDC (format is undocumented).
  89. Added “ExtraBytes” for one client (scan angle, local XYZ) to be written to LAS files. Got rid of Alt RGB.
  90. Updating ScanAngle calculation. Trying to make them all relative to nadir.
  91. Applying proximity filter after control/tie corrections.
  92. If more than 5 returns but only 5 returns allowed by format, using 1 to 4 and then the last return.
  93. Hiding sta file if not necessary.
  94. Updated control correction to better interpolate over distance independent of event step size.
  95. Added fore/aft distance filters
  96. Reading Riegl Model (miniVUX, DL, etc.) directly from SDC. This appears to be undocumented so it may not be perfect for new models).
  97. Added “ExtraBytes” for CL data per a client request.
  98. Updated ScanAngle calculation for all current scanners supported for back of car 45 & UAV configurations.
  99. Applying spatial proximity filters AFTER applying control/tie corrections.
  100. If more than 5 returns but only 5 returns allowed by format, using 1 to 4 and then the last return.
  101. Excluding Ties and Control folders from all file searches (to speed things up).
  102. In Stop-and-go (pause/resume) scanning with Velodyne, the EndingTime on some 'breaks' would be off by one event. This is just used for a lookup for convenience so no geometric issues.
  103. Breaking las files to separate files on pause-resume breaks
  104. Added user parameter for Scanner Rotation to Nadir. This is just in case the internal solution is somehow incorrect.
  105. Added Opt2Scl (Optech to ScanLook) conversion.
  106. Added horizontal tie point correction for streetview scanning.
  107. Modified some Yes/No/Cancel user queries to use a better option dialog.
  108. Fixed command line to once again work properly.
  109. Added automatic creation of an EXIF friendly data file to Ladybug.
  110. Fixed Cumulative Distance calculation in stop-and-go scenarios.
  111. Added option to disable Nag screens (are you sure, etc.?).

Version 1.0.135

Enhanced Interrupt operation.

After each file is completed it is written as the last Interrupt.
On Resume if Manually interrupted it asks you if you want to keep last
  partial file.
  

Added Segment/folder id to FileSourceId in LAS header.

Version 1.0.134

Version 1.0.122

  1. Leap Second fix particularly affecting the Velodyne data.

Version 1.0.119

  1. Added some messages when starting colorizing.
  2. Added Trimble Applanix POS input.
  3. Changed trajectory thinning to be greedy (get closest match less than filter settings).
  4. Added Profile (streetview/aerial) to Control Dialog.
  5. Asundry other minor items.

Version 1.0.118

  1. Some very minor fixes.

Version 1.0.117

  1. Fixed bug with first installation on a system creating 1kb las files. It wasn't creating a user folder for the calibration file.
  2. Added Ladybug offset logic for ladybug events and including image paths in event file (Ladybug*Extended.txt).
  3. Added one time prompt for Customer name.
  4. Added initial Quanergy stuff.
  5. Creating Velodyne*.kml files in pcap folder. This is handy to see exactly where the scanner was on and off, not just where the INS was tracking.
scanlook-pc-release-notes.1587834522.txt.gz · Last modified: 2020/04/25 10:08 by jeff.fagerman

Bitnami