User Tools

Site Tools


scanlook-pc-release-notes

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
scanlook-pc-release-notes [2019/11/05 10:17]
jeff.fagerman [Version 1.0.19X]
scanlook-pc-release-notes [2020/05/23 10:06] (current)
jeff.fagerman [Version 1.0.19X]
Line 71: Line 71:
   - Added ScanLook LB, Ladybug Boresight Measurement and Calculation options to the Tools menu. This makes the entire LB process a bit easier, especially the boresight calculation.   - Added ScanLook LB, Ladybug Boresight Measurement and Calculation options to the Tools menu. This makes the entire LB process a bit easier, especially the boresight calculation.
   - Fixed vZ control point threshold check (wasn'​t using Absolute value for magnitude).   - Fixed vZ control point threshold check (wasn'​t using Absolute value for magnitude).
- +  - When clicking on a control point measurement outside of any lidar points, the Z value is computed from the entire data set rather than returning 0's. 
 +  - Added Add-in manager to Programs menu. 
 +  - To File menu added Project Notes. 
 +  - Even if the Stationary Filter was disabled, it would still be enforced at 0.005 units. This has now been removed so the data can be piled up (some programs apparently cannot deal with a data discontinuity in time even though there is no discontinuity in coverage). 
 +  - Added option to generate square patches (still recommend the default of circles) for control and strip matching. 
 +  - For all Velodyne HD systems, if packets is not 9, it forces it back to 9. This could be a problem if somebody reconfigured their system to parameters other than the default. 
 +  - Added Ouster 16, 32, 64, and 128 and CL-360 scanners. 
 +  - Updated ZF-converter to handled scans that are paused or stopped and resumed. 
 +  - If the Time Correction on the Advanced Parameters dialog changes, then Reset Files is automatically invoked. 
 +  - Fixed NovAtelConvert.exe path for TerraPOS setups. Now checks all conditions for path. 
 +  - Expanded use to 128-lasers for Ouster and Velodyne. 
 +  - Fixed resize of Refresh button on Process Commands dialog. 
 +  - Smoother now defaults to current project. 
 +  - Smoother no longer pro-rates feathering distance but uses provided distance. 
 +  - Added more ZF-convert scripts (for defaults and no filters). 
 +  - Added Fix Rinex option to Process Commands scripts. 
 +  - Computing ScanDirection for LAS output of CL-90 and miniVUX-1DL. Updated all similar flags in LAS. 
 +  - Added point formats 6 & 7 of LAS definition and las format 1.4.  WKT not yet implemented for coordinate system. 
 +  - Dramatically improved speed of LAS file writes. 
 +  - If recording Riegl as rxp files and converting to sdc, reading model from sdc file.  
 +  - Fixed potential problem with folders contains &^, in folder name. Folders such as C:​\A&​B\... would cause some commands like control point measurement to fail. 
 +  - A critical angle function could cause problems with default boresights. 
 +  - Fixed GpsTime=0 data records being written after improving write speeds dramatically. 
 +  - Many updates to incorporate the XY tie point matching. 
 +  - Changed many of the Setup files to run silently. Only FARO couldn'​t be hidden. 
 +  - Added fore/Aft distance filters. 
 +  - Updated control/tie correction for better distance interpolation. 
 +  - Reading Riegl Model directly from SDC (format is undocumented). 
 +  - Added "​ExtraBytes"​ for one client (scan angle, local XYZ) to be written to LAS files. Got rid of Alt RGB. 
 +  - Updating ScanAngle calculation. Trying to make them all relative to nadir. 
 +  - Applying proximity filter after control/tie corrections. 
 +  - If more than 5 returns but only 5 returns allowed by format, using 1 to 4 and then the last return. 
 +  - Hiding sta file if not necessary. 
 +  - Updated control correction to better interpolate over distance independent of event step size. 
 +  - Added fore/aft distance filters 
 +  - Reading Riegl Model (miniVUX, DL, etc.) directly from SDC. This appears to be undocumented so it may not be perfect for new models). 
 +  - Added "​ExtraBytes"​ for CL data per a client request. 
 +  - Updated ScanAngle calculation for all current scanners supported for back of car 45 & UAV configurations. 
 +  - Applying spatial proximity filters AFTER applying control/tie corrections. 
 +  - If more than 5 returns but only 5 returns allowed by format, using 1 to 4 and then the last return. 
 +  - Excluding Ties and Control folders from all file searches (to speed things up). 
 +  - In Stop-and-go (pause/​resume) scanning with Velodyne, the EndingTime on some '​breaks'​ would be off by one event. This is just used for a lookup for convenience so no geometric issues. 
 +  - Breaking las files to separate files on pause-resume breaks 
 +  - Added user parameter for Scanner Rotation to Nadir. This is just in case the internal solution is somehow incorrect. 
 +  - Added Opt2Scl (Optech to ScanLook) conversion. 
 +  - Added horizontal tie point correction for streetview scanning. 
 +  - Modified some Yes/​No/​Cancel user queries to use a better option dialog. 
 +  - Fixed command line to once again work properly. 
 +  - Added automatic creation of an EXIF friendly data file to Ladybug. 
 +  - Fixed Cumulative Distance calculation in stop-and-go scenarios. 
 +  - Added option to disable Nag screens (are you sure, etc.?). 
 +  - If a raw data file is missing the user is warned. E.g. if VelodyneData_2.pcap is missing. 
 +  - The Distance calculation in the Graphics tool was incorrect for accumulated,​ multiple leg measurements. 
 +  - Added the NCTech 360 iStar camera boresight and colorization. 
 +  - 
  
 ===== Version 1.0.135 ===== ===== Version 1.0.135 =====
scanlook-pc-release-notes.1572977873.txt.gz · Last modified: 2019/11/05 10:17 by jeff.fagerman

Bitnami